Excel - Fonction CONCATENER

Asked By PYR on 22-Feb-09 11:42 AM
Bonjour à tous.

Sous Excel 2003, je suis tombé sur une impossibilité (de ma part) de trouver
la solution rapide. J'ai donc trouvé une solution palliative mais cela ne me
satisfait pas.

Voici mon problème :

J'ai, dans une cellule, une formule (entrée avec CTRL+MAJ+ENTREE) ==> qui
devrait me donner le résultat "PQR" si tout allait bien.
Quand j'utilise la sélection d'une partie de la formule et que je fais F9,
je vois l'évolution des calculs.
Après plusieurs manipulations de ce type, j'arrive à la dernière formule qui
ne donne pas le résultat voulu : =CONCATENER({"P"."Q"."R"})

Le résultat fournit est "P" sans les "Q" et "R".

Pourriez-vous me dire pourquoi la fonction CONCATENER ne concatène pas une
matrice ?
Avez-vous en magazin, une solution ?

En vous remerciant par avance




J@@ replied on 22-Feb-09 12:25 PM
Bonjour PYR

ceci fonctionne chez moi sous excel 2000.
=CONCATENER(P1;Q1;R1)
formule normale, rentrée par simple "enter"

cordialement
J@@

PYR a écrit :
J@@ replied on 22-Feb-09 12:27 PM
oupss, mal lu ta question.
ma réponse est à côté de la plaque
désolé
J@@

PYR a écrit :
LSteph replied on 22-Feb-09 01:02 PM
Bonjour,

Pour concatener on peut utiliser le &
="P"&"Q"&"R"

Pour ta question matricielle, cela ne donnera pas exactement ce que tu
attends si j'ai bien compris..

il faudrait écrire dans trois cellules selon le cas verticalement ou
horizontalement :
=CONCATENER({"P";"Q";"R"}
=CONCATENER({"P"."Q"."R"})
attention traiter ceci en matricielle revient à
Concatener séparément p puis Q puis R chacun dans une cellule.
Soit un seul chr par cellule, puisqu'il n'y a qu'un seul caractère dans
la matrice.

De même si tu entres en matricielle dans trois cellules verticales
=CONCATENER({"P";"Q";"R"};{"M";"N";"O"})

tu obtiens,
PM
QN
RO

L'autre le pb est que concatener utilise de 1 à 30 items mais
il faut tous les préciser
=concatener(a1;a2;a3;a4..a15)
ainsi ceci n'ira pas =concatener(a1:a15)

Une astuce  pour regrouper un texte sera donc  parfois d'incrémenter les
concaténations avec le résultat de la formule de concaténation précédente

exemple en b2
=a1&a2
puis en b3
=b2&a3
puis recopier vers bas jusqu'en 15
...
=b14&a15

Cordialement.

--
lSteph

PYR a écrit :
michdenis replied on 22-Feb-09 01:06 PM
Pour pouvoir affiché ce résultat : P Q et R dans des cellules,
tu dois sélectionner 3 cellules sur une ligne, utiliser la touche F2 pour
passer en mode édition et coller ta formule dans la barre
de formule. Tu valides avec CTRL + MAJ + ENTER
et dans chaque cellule apparaîtra P Q R




Bonjour à tous.

Sous Excel 2003, je suis tombé sur une impossibilité (de ma part) de trouver
la solution rapide. J'ai donc trouvé une solution palliative mais cela ne me
satisfait pas.

Voici mon problème :

J'ai, dans une cellule, une formule (entrée avec CTRL+MAJ+ENTREE) ==> qui
devrait me donner le résultat "PQR" si tout allait bien.
Quand j'utilise la sélection d'une partie de la formule et que je fais F9,
je vois l'évolution des calculs.
Après plusieurs manipulations de ce type, j'arrive à la dernière formule qui
ne donne pas le résultat voulu : =CONCATENER({"P"."Q"."R"})

Le résultat fournit est "P" sans les "Q" et "R".

Pourriez-vous me dire pourquoi la fonction CONCATENER ne concatène pas une
matrice ?
Avez-vous en magazin, une solution ?

En vous remerciant par avance
PYR replied on 22-Feb-09 01:50 PM
Merci de vous préoccuper de mon souci.

J'avais trouvé des manips pour résoudre mon souci (on va dire qui était
urgent au moment où il s'est présenté)
Je voulais juste comprendre pourquoi ce que je voulais faire me fonctionnait
pas à ce moment-là.

Je vous explique mon cas (il est très simple finalement) :
En A1 : j'ai 808182
Sachant que 80 est le code ASCII de "P", 81 celui de "Q" et 82 celui "R",
je voulais, en un seul calcul (une seule cellule utilisée) avoir le
transcodage des 3 codes en 3 caractères.
En B1: j'ai donc mis {=CONCATENER(CAR(CNUM(STXT(A1;{1;3;5};2))))}
Et oh surprise, le résultat ne donne que "P", pas de concaténation avec les
2 autres lettres.

Quand je fais {=SOMME({1.2.3})} ou =SOMME({1.2.3}), j'obtiens bien la somme
de 6 ==> la somme s'exécute correctement
Alors pourquoi la concaténation s'exécute (pas de plantage) mais
incomplètement.
Si vous avez un élément de réponse, je suis preneur ==> ca c'est pour la
culture générale sur Excel

Maintenant, peut-être que vous pourriez réussir ce que je n'ai pas su faire
et comme je n'ai pas trouvé d'autres idées en dehors de ce que j'avais saisi
en B1 ...
LSteph replied on 22-Feb-09 02:57 PM
re,

=CAR(GAUCHE(A1;2))&CAR(STXT(A1;2;3))&CAR(DROITE(A1;2))

sinon Concatener fonctionne pour ce qu'il est sensé faire.

Ce n'est pas comparable:
Somme admet par exemple A1:A10
ce n'est pas le cas  avec Concatener qui admet de 1 à 30 items
mais ainsi A1;A2;A3...
de plus on concatène du texte et on additione des nombres c'est différent.

Pour le reste relis ma précédente réponse.

--
lSteph

PYR a écrit :