Excel - Funktion Suchen gibt #WERT

Asked By Uli Schoch on 12-Dec-09 08:38 AM
Hallo
In einer Excel 2007-Tabelle m?chte ich in einer Spalte Strings darauf
untersuchen, ob ein bestimmtes Zeichen drin ist, z.B. ein "W". Dieses kann
aber irgendwo im String oder gar nicht vorhanden sein. Mit der Funktion
die Postiton des Zeichens. Wenn das Zeichen aber nicht drin ist, kommt die
Meldung #WERT.
Ich m?chte aber in jedem Fall eine vern?nftigen R?ckgabewert der Funttion
haben, wenn das Zeichen nicht drin ist, w?re "0" vern?nftig. Wie kann ich
das machen?

Gruss
Uli




Claus Busch replied to Uli Schoch on 12-Dec-09 08:49 AM
Hallo Uli,

Am Sat, 12 Dec 2009 14:38:05 +0100 schrieb Uli Schoch:


probiers mal mit:
=ISTZAHL(SUCHEN("w";A1))
Ergibt WAHR, wenn der Suchstring vorhanden, und FALSCH, falls nicht
vorhanden.


Mit freundlichen Gr?ssen
Claus Busch
--
Win XP PRof SP2 / Vista Ultimate SP2
Office 2003 SP2 /2007 Ultimate SP2
Jens Kammler replied to Claus Busch on 12-Dec-09 09:14 AM
Ich erweitere Claus' Variante zu:

=WENN(ISTZAHL(SUCHEN("W";A1))=FALSCH;0;SUCHEN("W";A1))

Gr??e Jens
Claus Busch replied to Jens Kammler on 12-Dec-09 09:41 AM
Hallo Jens,

Am Sat, 12 Dec 2009 15:14:38 +0100 schrieb Jens Kammler:


da der OP ?ber xl2007 verf?gt, geht es noch einfacher mit:
=WENNFEHLER(SUCHEN("w";A1);0)


Mit freundlichen Gr?ssen
Claus Busch
--
Win XP PRof SP2 / Vista Ultimate SP2
Office 2003 SP2 /2007 Ultimate SP2
Uli Schoch replied to Claus Busch on 12-Dec-09 10:26 AM
Danke an alle, so funktionierts!

Gruss
Uli