Excel - Cómo_obtener_promedio_de_un_rango_con_celdas_en_blanco?

Asked By Alex on 31-May-10 05:12 PM
Si quiero obtener el promedio de todo lo que aparezca en cierta columna,
pero SIN TOMAR EN CUENTA las celdas vac?as o cuyo valor sea 0???

Por ejemplo, en B301, quiero que aparezca el valor de
=PROMEDIO(B2:B300), pero hasta ahora s?lo tengo valores en los registros
B2:B8. La f?rmula me est? promediando todas las celdas siguientes, con
valor de 0. C?mo evitarlo?




Héctor Miguel replied to Alex on 31-May-10 06:25 PM
hola, Alex !


-> si consideras lo que dice la ayuda en linea {F1} de excel acerca de la funcion promedio...
- ... los argumentos deben ser numeros o nombres, matrices o referencias que contengan numeros
- ... tenga en cuenta la diferencia entre las celdas vacias y las que contienen el valor cero ...
- ... no se cuentan las celdas vacias, pero se cuentan los valores cero.
- ... si un argumento matricial o de referencia contiene texto, valores logicos o celdas vacias,
- ... esos valores se pasan por alto; sin embargo, se incluyen las celdas cuyo valor sea 0

-> y una comparacion entre la funcion promedio y (algunas) formas de contar elementos...
1.- promedio(a1:a30)
2.- suma(a1:a30)/filas(a1:a30)
3.- suma(a1:a30)/contar(a1:a30)
4.- suma(a1:a30)/contara(a1:a30)
5.- suma(a1:a30)/contar.si(a1:a30,">0")    o una matricial... =promedio(si(a1:a30>0,a1:a30,""))
6.- suma(a1:a30)/contar.si(a1:a30,"<>0")

-> todas mostraran diferentes resultados segun (la combinacion que se tenga de) los elementos en la matriz...
(celdas vacias... celdas con textos... caldas con valores cero... combinaciones... etc.)
la #3 es la (unica?) forma de contar elementos que es constante con los resultados de la funcion (promedio)
(ya que...) la funcion contar omite celdas con textos (pero incluye valores en cero)

saludos,
hector.
Aladino replied to Alex on 31-May-10 06:23 PM
Hola, Alex

Si utilizas Excel 2007 puedes usar la funci=F3n PROMEDIO.SI.CONJUNTO de
esta manera:

=3DPROMEDIO.SI.CONJUNTO(B2:B300;B2:B300;">0";B2:B300;"<>""")

En versiones anteriores hay distintas maneras de conseguir el mismo
resultado. Te propongo una f=F3rmula matricial como la siguiente:

=3DPROMEDIO(SI(B2:B300<>0;B2:B300))

Para obtener el resultado esperado has de pulsar ctrl + mayus+intro.

Tenemos un curso gratuito en Excel 2007 via mail por si quieres
aprender un poco m=E1s sobre Excel.

www.5incoaprendices.com

ros
n
Diana replied to Alex on 01-Jun-10 03:57 AM
Hola, Alex

La respuesta de Aladino mediante funci=F3n matricial promedio est=E1
incompleta puesto que le falta poner las comillas al final para
englobar las celdas vac=EDas. Se le habr=E1 olvidado. Y en cuanto a la de
Hector solo funcionar=E1 si sustituyes las comas por punto y coma. Te lo
digo para evitarnos aquello de que la formula no funciona.

En excel.tips.net puedes encontrar mucha informaci=F3n al respecto.

Diana
AnSanVal replied to Diana on 01-Jun-10 01:45 PM
Hola Diana.

Tal vez tú cuentas con información que yo desconozco. Lo digo por...


... ya que si el separador de argumentos de Alex es la coma; la solución de
Héctor deberá funcionarle correctamente.


Saludos: Antonio.
Diana replied to AnSanVal on 01-Jun-10 04:30 PM
Anda, pues tienes raz=F3n. No s=E9 por qu=E9 supuse que Alex estaba
utilizando Excel en espa=F1ol! Como a nuestro experto en Excel en el
trabajo siempre le inundan con este mismo error de las comas como
separador, al traducir las soluciones del grupo en ingles siempre se
olvidan de los separadores en espa=F1ol.

Gracias por la observaci=F3n, Antonio

omas
n de
AnSanVal replied to Diana on 01-Jun-10 04:47 PM
Hola Diana.

Anda, pues tienes razón. No sé por qué supuse que Alex estaba
utilizando Excel en español! Como a nuestro experto en Excel en el
trabajo siempre le inundan con este mismo error de las comas como
separador, al traducir las soluciones del grupo en ingles siempre se
olvidan de los separadores en español.

Gracias por la observación, Antonio

------------------------

Gracias a ti por tu respuesta y  sobre todo por intentar compartir  ;-)

Saludos: Antonio.
Alex replied to Diana on 01-Jun-10 05:25 PM
Gracias a todos por su ayuda!!

Efectivamente lo que uso es Excel 2003 en Espa?ol (con punto y coma)

Y abusando de su generosidad, les planteo lo siguiente:

De las soluciones que me ofrecen la que eleg? fue
=SUMA(I2:I300)/CONTAR.SI(I2:I300;"<>0")
y funciona de maravilla pero... quisiera que la celda donde est? esa
f?rmula (I301), se actualice de acuerdo al filtro aplicado, es decir que
si en otra columna (nombre de materias, por ejemplo) se plicara un
filtro (matem?ticas, por ejemplo), que el promedio, al fondo de la
columna I fuera s?lo de los valores expuestos a la vista (sin que los
valores ocultos (sean 0, u otro valor) afecte el promedio.

No s? si para eso pueda usar la funci?n PROMEDIO porque ?sta s? cuenta
las celdas en 0 (aunque no las vac?as), y en esa columna todas las
celdas son f?rmulas.

Gracias de antemano.

El 01/06/2010 15:30, Diana escribi?:
AnSanVal replied to Alex on 01-Jun-10 07:16 PM
Hola Alex.

Para ello existe la función SUBTOTALES (consulta la ayuda para más
información). Por ejemplo para sumar sólo los visibles:
=SUBTOTALES(109;I2:I300)

El código para PROMEDIO es 101, en vez de 109.

Saludos: Antonio.
***********************