Excel - somma colonna

Asked By pippo on 30-Sep-10 04:42 AM
Salve a tutti,

con la seguente sintassi si esegue la somma su un intervallo di celle
di una colonna:

=3DSOMMA(AJ2:AJ13)

E' possibile scrivere la funzione in modo che esegua la somma su tutte
le celle piene della colonna AJ? (che potrebbero essere AJ14,AJ15...).
Ovvero esiste una sintassi che permetta di dire "somma tutte le celle
della colonna" senza dover dire qual'=E8 l'ultima cella?

grazie




paoloard replied to pippo on 30-Sep-10 05:27 AM
=SOMMA(A:A)
--
fai sapere
ciao paoloard
http://www.riolab.org
pippo replied to paoloard on 30-Sep-10 05:36 AM
c-8fbd-994319a84901@j18g2000yqd.googlegroups.com...


grazie, scusa se rompo ancora e se dovesse sommare a partire da A2
fino A"infinito"?

=E8 possibile?
paoloard replied to pippo on 30-Sep-10 06:03 AM
? possibile devi solo mettere come estremo dell'intervallo A2:l'ultima cella
del foglio (nella versione 2010 ? la 1.048.756).
Per? mi chiedo perch?, dato che se anche nella prima cella ci fosse una
stringa la somma non ne verrebbe influenzata.
Altro discorso se in A1 vi fosse un numero o una data, in quel caso sarebbe
sufficiente detrarla dalla somma, cio?
=SOMMA(A:A)-A1
--
fai sapere
ciao paoloard
http://www.riolab.org
pippo replied to paoloard on 30-Sep-10 06:08 AM
3-bebe-94908621ea34@i3g2000yql.googlegroups.com...
roups.com...
e
te
).
e
cella
na
be

nella prima cella (e pure nella seconda cella) ci metto la formula per
fare la somma su tutta la colonna :-)
paoloard replied to pippo on 30-Sep-10 07:43 AM
cut

per avere il valore dell'ultima riga del foglio posizionati su di una
colonna vuota e premi CTRL+FrecciaGi?, leggi il numero di riga e immmettilo
come estremo del tuo intervallo.
--
fai sapere
ciao paoloard
http://www.riolab.org
Scossa replied to pippo on 30-Sep-10 07:54 AM
Definisci un "nome":

Menu inserisci -> Nome -> definisci ::
nome :: sm
riferito a :: =3DFoglio1!A$2:A$65536

n.b.: riferimento di colonna relativo di riga assoluto ($)

da usare cos=EC:
In A1:: =3DSomma(sm)
in B1:: =3DSomma(sm)

Bye!
Scossa
Scossa replied to Scossa on 30-Sep-10 07:55 AM
Ovviamente per excel 2003, per il 2007 e 2010 sostituisci 65536 con il
valore dell'ultima riga ammessa dal programma.

Bye!
Scossa