Excel - Somma valori di un intervallo sulla base di criterio ???

Asked By Goldrake on 10-Jan-12 06:41 AM
Scusate se la domanda =E8 gi=E0 stata affrontata ma non ne vengo fuori.

Data una tabella contenente delle date e dei valori:

Data             Euro
01/01/2011    100
15/01/2011    200
01/02/2011    150
01/03/2011    200
15/03/2011    200

Vorrei creare una tabella di riepilogo che contenga il totale dei
valori di ogni mese e il calcolo di quanti giorni ci sono per ogni
mese. Mi spiego con un esempio che =E8 meglio:

Gennaio    300     2
Febbraio    150    1
Marzo       400     2

Immagino che con due funzioni sia possibile risolvere ma non riesco a
capire come combinare le cose.

Grazie se mi aiuterete




Mauro Gamberini replied to Goldrake on 10-Jan-12 09:25 AM
Data una tabella contenente delle date e dei valori:

Data             Euro
01/01/2011    100
15/01/2011    200
01/02/2011    150
01/03/2011    200
15/03/2011    200

Vorrei creare una tabella di riepilogo che contenga il totale dei
valori di ogni mese e il calcolo di quanti giorni ci sono per ogni
mese. Mi spiego con un esempio che ? meglio:

Gennaio    300     2
Febbraio    150    1
Marzo       400     2

********************************************

Se(se) ho capito:

CONTA.SE()
http://office.microsoft.com/it-it/excel-help/conta-se-HP005209029.aspx

SOMMA.SE()
http://office.microsoft.com/it-it/excel-help/somma-se-HP005209292.aspx

--
---------------------------
Mauro Gamberini
Microsoft MVP - Excel
http://www.riolab.org/
http://www.maurogsc.eu/
Andrea.9 replied to Mauro Gamberini on 10-Jan-12 09:41 AM
per la somma:
=SOMMA(SE(MESE($A$1:$A$9)=RIF.RIGA(A1);$B$1:$B$9))
per la conta:
=SOMMA(SE(MESE($A$1:$A$9)=RIF.RIGA(A1);1))
entrambe da trascinare e matriciali (Ctrl+Shift+Invio)
adatta l'intervallo alla tua tabella dati
ciao
andrea
spid2 replied to Andrea.9 on 10-Jan-12 10:44 AM
Ciao Andrea e grazie per gli esempi.
Funziona tutto (quasi) perfettamente.
Ho riscontrato un problema sulla funzione che conta i mesi.
Il problema l'ho riscontrato solo sul mese di gennaio , nel senso che mi re=
stituiva dei valori anomali pi=F9 alti.

Dopo un p=F2 di test ho scoperto che se la cella contenente la data =E8 vuo=
ta, lui considera comunque il valore 1 e lo aggiunge.

Il problema si verifica perch=E8 io come range passo alla funzione 365 righ=
e (i giorni dell'anno) che non sono necessariamente sempre piene.

Ho fatto anche la verifica matematica , contando le righe piene e facendo l=
a differenza con 365 ed effettivamente i conti tornano (anche se errati).

Non so se =E8 un comportamento normale.=20
Si pu=F2 risolvere ?

Grazie
Andrea.9 replied to spid2 on 10-Jan-12 11:26 AM
si pu=F2 risolvere tutto (o quasi)
pero' tu non avevi detto di avere delle celle "data" vuote ma con le
corrispondenti celle "importo" con un valore.
se ho capito bene cosa vuoi fare:
=3DSOMMA(SE(MESE($A$2:$A$365)=3DRIF.RIGA(A1);$B$2:$B$365*SE(($A$2:$A
$365)<>"";1)))
=3DSOMMA(SE(MESE($A$2:$A$365)=3DRIF.RIGA(A1);1*SE(($A$2:$A$365)<>"";1)))
sempre matriciali da trascinare per i 12 celle.
ciao
andrea
spid2 replied to Andrea.9 on 10-Jan-12 11:43 AM
SEI UN MITO !!!

Cena offerta se passi dalle mie parti (Liguria) !

Grazieeee
Andrea.9 replied to spid2 on 10-Jan-12 12:57 PM
caro mio .... sono di genova
e una cosa cosi' non si deve dire a un genovese se non si e' pronti
alle conseguenze ;-)
ciao
andrea
eliano replied to Andrea.9 on 10-Jan-12 02:38 PM
Applausi!
Vediamo pero' come va a finire. LiguriaxLiguria: che cambia ??
Attendiamo gli esiti dello scontro epico fra "braccini corti".:-))
Eliano
eliano replied to Andrea.9 on 10-Jan-12 02:38 PM
Ovviamente io punto su Andrea. :-))
Andrea.9 replied to eliano on 10-Jan-12 03:13 PM
della serie:
Genovese uccide ventriloquo scozzese dopo aver dichiarato:"Pago io il
conto!"

Ma no, non e' vero, non siamo avari, siamo parsimoniosi.
Anche perche' qui non si sono che rimasti gli occhi per piangere (e
qualcuno si e' gia' venduto anche una cornea).

PS: a proposito ......
..... vendo punti della patente.
Se qualcuno fosse interessato ....... XD

ciao
andrea
r replied to Andrea.9 on 10-Jan-12 04:35 PM
forse Mauro :-D
r
r replied to Andrea.9 on 10-Jan-12 04:59 PM
accorcio va:
=3DSOMMA((A$2:A$365<>"")*(MESE(A$2:A$365)=3DRIF.RIGA(A1))*B$2:B$365)

=3DSOMMA((A$2:A$365<>"")*(MESE(A$2:A$365)=3DRIF.RIGA(A1)))
entrambe da confermare con ctrl+maiusc+invio

saluti
r
eliano replied to Andrea.9 on 10-Jan-12 05:29 PM
LOL
Andrea.9 replied to r on 11-Jan-12 03:27 AM
e te pareva ..... XD
ciao
andrea
Mauro Gamberini replied to r on 11-Jan-12 08:11 AM
forse Mauro :-D
r
*********************

Troppo veloce per gli autovelox...
--
---------------------------
Mauro Gamberini
Microsoft MVP - Excel
http://www.riolab.org/
http://www.maurogsc.eu/
spid2 replied to Andrea.9 on 14-Jan-12 11:19 AM
Ovviamente, la cena offerta =E8 limitata al men=F9 del giorno a prezzo popo=
lare.

Che pensavi... ???

Grazie ancora ma stai sintonizzato che forse ti chieder=F2 ancora aiuto per=
ch=E8 devo evolvere la funzione.

Ma per quello, al max, posso offriri l'aperitivo prima della cena

Grazie